Доступные версии документации

Автоматическая установка

ADO.NET-провайдер автоматически устанавливается в процессе установки СУБД ЛИНТЕР, если выбрана его установка (рис. 1).

Примечание

Для установки ADO.NET-провайдера необходимы права администратора ОС.

Возможные способы установки:

  • установка в GAC (глобальный кэш сборок) необходима для совместного использования ADO.NET-провайдера несколькими приложениями. Если выбрать установку данного компонента, то сборка System.Data.LinterClient.dll будет установлена в GAC и на вкладку .NET диалогового окна Add Reference;

    Автоматическая установка ADO.NET-провайдера СУБД ЛИНТЕР
    Рисунок 1. Автоматическая установка ADO.NET-провайдера СУБД ЛИНТЕР

  • регистрация в Machine.Config (Файлы конфигурации компьютеров) позволяет разрабатывать приложения, содержащие объекты DbProviderFactory. Если выбрать установку данного компонента, то поставщик System.Data.LinterClient будет добавлен в файл machine.config на локальном компьютере;

  • LINQ-провайдер позволяет разрабатывать приложения, содержащие запросы LINQ (Language-Integrated Query). Если выбрать установку данного компонента, то сборка System.Data.Linq.Linter.dll будет установлена в GAC;

  • Entity-провайдер позволяет разрабатывать приложения, использующие объектно-реляционный модуль сопоставления Entity Framework. Если выбрать установку данного компонента, то сборка System.Data.LinterClient.Entity.dll будет установлена в GAC;

  • интеграция с Visual Studio позволяет управлять структурой БД и разрабатывать клиентские приложения, ориентированные на работу с данными, используя Средства для работы с источниками данных в Visual Studio.

Интеграция с Visual Studio 2013 требует дополнительных действий со стороны пользователя. Причина этого – ошибка Visual Studio 2013: в файле devenv.exe.config для сборки Microsoft.VisualStudio.Package.LanguageService.10.0.dll указано перенаправление на версию 12.0.0.0, хотя в GAC установлена только версия 10.0.0.0. Описание ошибки на английском языке можно найти по ссылке. Для устранения данной ошибки нужно открыть файл devenv.exe.config в текстовом редакторе и заменить 12.0.0.0 на 10.0.0.0:

<dependentAssembly>
  <assemblyIdentity name="Microsoft.VisualStudio.Package.LanguageService.10.0"
    publicKeyToken="b03f5f7f11d50a3a" culture="neutral"/>
  <bindingRedirect oldVersion="2.0.0.0-11.0.0.0" newVersion="10.0.0.0"/>
</dependentAssembly>
Заметили ошибку?
Выделите текст и нажмите Ctrl + Enter